# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)"
test_str = ("1\n"
"00:00:53,000 --> 00:00:57,000\n"
"<any text that may span multiple lines>\n\n"
"2\n"
"00:01:28,000 --> 00:01:35,000\n"
"<any text that may span multiple lines>\n\n"
"3\n"
"00:02:09,000 --> 00:02:14,000\n"
"<any text that may span multiple lines>\n\n"
"4\n"
"00:02:14,000 --> 00:02:19,000\n"
"<any text that may span multiple lines>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.