use strict;
my $str = '1
00:00:53,000 --> 00:00:57,000
<any text that may span multiple lines>
2
00:01:28,000 --> 00:01:35,000
<any text that may span multiple lines>
3
00:02:09,000 --> 00:02:14,000
<any text that may span multiple lines>
4
00:02:14,000 --> 00:02:19,000
<any text that may span multiple lines>';
my $regex = qr/(?<hour>\d+):(?<minute>\d+):(?<second>\d+),(?<msecond>\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}