# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\?(?!php)/<?php/g;t' <<< "<?
$var1 = \"This is just some dummy test.\";
echo $var1;
?>
Leave this tag alone:
<?php
echo $var2;
?>"