import Foundation
let pattern = #"<\?(?!php)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?
$var1 = "This is just some dummy test.";
echo $var1;
?>
Leave this tag alone:
<?php
echo $var2;
?>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<?php"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)