import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\?(?!php)";
final String string = "<?\n"
+ "$var1 = \"This is just some dummy test.\";\n"
+ "echo $var1;\n"
+ "?>\n"
+ "Leave this tag alone:\n"
+ "<?php\n"
+ "echo $var2;\n"
+ "?>";
final String subst = "<?php";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}