$re = '~<\?(?!php)~';
$str = '<?
$var1 = "This is just some dummy test.";
echo $var1;
?>
Leave this tag alone:
<?php
echo $var2;
?>';
$subst = "<?php";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;