# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\?(?!php)"
test_str = ("<?\n"
"$var1 = \"This is just some dummy test.\";\n"
"echo $var1;\n"
"?>\n"
"Leave this tag alone:\n"
"<?php\n"
"echo $var2;\n"
"?>")
subst = "<?php"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.