use strict;
my $str = '<?
$var1 = "This is just some dummy test.";
echo $var1;
?>
Leave this tag alone:
<?php
echo $var2;
?>';
my $regex = qr~<\?(?!php)~p;
my $subst = '<?php';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";