re = /<\?(?!php)/
str = '<?
$var1 = "This is just some dummy test.";
echo $var1;
?>
Leave this tag alone:
<?php
echo $var2;
?>'
subst = '<?php'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result