#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<\?(?!php)"
Local $sString = "<?" & @CRLF & _
"$var1 = "This is just some dummy test.";" & @CRLF & _
"echo $var1;" & @CRLF & _
"?>" & @CRLF & _
"Leave this tag alone:" & @CRLF & _
"<?php" & @CRLF & _
"echo $var2;" & @CRLF & _
"?>"
Local $sSubst = "<?php"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)