#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "font-family:\s*'([^']*)'"
Local $sString = "@font-face {" & @CRLF & _
" font-family: 'fancy-icons';" & @CRLF & _
" src:" & @CRLF & _
" url('#{$icon-font-path}/fancy-icons.ttf?p3owtd') format('truetype')," & @CRLF & _
" url('#{$icon-font-path}/fancy-icons.woff?p3owtd') format('woff')," & @CRLF & _
" url('#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons') format('svg');" & @CRLF & _
" font-weight: normal;" & @CRLF & _
" font-style: normal;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")