package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`font-family:\s*'([^']*)'`)
var str = `@font-face {
font-family: 'fancy-icons';
src:
url('#{$icon-font-path}/fancy-icons.ttf?p3owtd') format('truetype'),
url('#{$icon-font-path}/fancy-icons.woff?p3owtd') format('woff'),
url('#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons') format('svg');
font-weight: normal;
font-style: normal;
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}