$re = '/font-family:\s*\'([^\']*)\'/';
$str = '@font-face {
font-family: \'fancy-icons\';
src:
url(\'#{$icon-font-path}/fancy-icons.ttf?p3owtd\') format(\'truetype\'),
url(\'#{$icon-font-path}/fancy-icons.woff?p3owtd\') format(\'woff\'),
url(\'#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons\') format(\'svg\');
font-weight: normal;
font-style: normal;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);