# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"font-family:\s*'([^']*)'"
test_str = ("@font-face {\n"
" font-family: 'fancy-icons';\n"
" src:\n"
" url('#{$icon-font-path}/fancy-icons.ttf?p3owtd') format('truetype'),\n"
" url('#{$icon-font-path}/fancy-icons.woff?p3owtd') format('woff'),\n"
" url('#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons') format('svg');\n"
" font-weight: normal;\n"
" font-style: normal;\n"
"}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.