use strict;
my $str = '@font-face {
font-family: \'fancy-icons\';
src:
url(\'#{$icon-font-path}/fancy-icons.ttf?p3owtd\') format(\'truetype\'),
url(\'#{$icon-font-path}/fancy-icons.woff?p3owtd\') format(\'woff\'),
url(\'#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons\') format(\'svg\');
font-weight: normal;
font-style: normal;
}';
my $regex = qr/font-family:\s*'([^']*)'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}