const regex = /font-family:\s*'([^']*)'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('font-family:\\s*\'([^\']*)\'', 'g')
const str = `@font-face {
font-family: 'fancy-icons';
src:
url('#{\$icon-font-path}/fancy-icons.ttf?p3owtd') format('truetype'),
url('#{\$icon-font-path}/fancy-icons.woff?p3owtd') format('woff'),
url('#{\$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons') format('svg');
font-weight: normal;
font-style: normal;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}