import Foundation
let pattern = #"font-family:\s*'([^']*)'"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
@font-face {
font-family: 'fancy-icons';
src:
url('#{$icon-font-path}/fancy-icons.ttf?p3owtd') format('truetype'),
url('#{$icon-font-path}/fancy-icons.woff?p3owtd') format('woff'),
url('#{$icon-font-path}/fancy-icons.svg?p3owtd#fancy-icons') format('svg');
font-weight: normal;
font-style: normal;
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)