# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{1,2}.*$//gm;t' <<< "mary poppins 50th anniversary edition
the blues brothers 25th anniversary edition"