const regex = /\d{1,2}.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}.*$', 'gm')
const str = `mary poppins 50th anniversary edition
the blues brothers 25th anniversary edition`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);