$re = '/\d{1,2}.*$/m';
$str = 'mary poppins 50th anniversary edition
the blues brothers 25th anniversary edition';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;