import re
regex = re.compile(r"\d{1,2}.*$", flags=re.MULTILINE)
test_str = ("mary poppins 50th anniversary edition\n"
"the blues brothers 25th anniversary edition")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)