#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d{1,2}.*$"
Local $sString = "mary poppins 50th anniversary edition" & @CRLF & _
"the blues brothers 25th anniversary edition"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)