re = /\d{1,2}.*$/m
str = 'mary poppins 50th anniversary edition
the blues brothers 25th anniversary edition'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result