# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\d{3}_[a-zA-Z]+)(\d{3}\.jpg)/\1_\2/g;t' <<< "205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].
321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
...
321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]"