import re
regex = re.compile(r"\b(\d{3}_[a-zA-Z]+)(\d{3}\.jpg)")
test_str = ("205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
"205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].\n\n"
"321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
"321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info] \n"
"321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
" ...\n"
"321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n\n"
"205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
"205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
"205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]\n"
"205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]")
subst = "\\1_\\2"
result = regex.sub(subst, test_str)
if result:
print(result)