#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(\d{3}_[a-zA-Z]+)(\d{3}\.jpg)"
Local $sString = "205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
"205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]." & @CRLF & _
"" & @CRLF & _
"321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
"321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info] " & @CRLF & _
"321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
" ..." & @CRLF & _
"321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
"" & @CRLF & _
"205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
"205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
"205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]" & @CRLF & _
"205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]"
Local $sSubst = "\1_\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)