import Foundation
let pattern = #"\b(\d{3}_[a-zA-Z]+)(\d{3}\.jpg)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].
321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
...
321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1_\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)