// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(\d{3}_[a-zA-Z]+)(\d{3}\.jpg)").unwrap();
let string = "205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info].
321_AliceAllison001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
321_AliceAllison003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
...
321_AliceAllison125.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson001.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson002.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson_003.jpg [size_info] [date_info] [geo_location_info] ... [other info]
205_CarlCarlson007.jpg [size_info] [date_info] [geo_location_info] ... [other info]";
let substitution = "\\1_\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}