# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(user\d+)$/script1.php?username=$1/gm;t' <<< "user1
clothes/jackets/cool-red-jacket-25"