import Foundation
let pattern = #"^(user\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
user1
clothes/jackets/cool-red-jacket-25
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"script1.php?username=$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)