#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(user\d+)$"
Local $sString = "user1" & @CRLF & _
"clothes/jackets/cool-red-jacket-25"
Local $sSubst = "script1.php?username=$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)