package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(user\d+)$`)
var str = `user1
clothes/jackets/cool-red-jacket-25`
var substitution = "script1.php?username=$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}