// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(user\d+)$").unwrap();
let string = "user1
clothes/jackets/cool-red-jacket-25";
let substitution = "script1.php?username=$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}