use strict;
my $str = 'user1
clothes/jackets/cool-red-jacket-25';
my $regex = qr/^(user\d+)$/mp;
my $subst = 'script1.php?username=$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";