# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)/\1\2 years/gm;t' <<< "h1,h2,h3
A1,age:15,hh
B3,age:10,fg"