#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)"
Local $sString = "h1,h2,h3" & @CRLF & _
"A1,age:15,hh" & @CRLF & _
"B3,age:10,fg"
Local $sSubst = "\1\2 years"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)