import re
regex = re.compile(r"(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)", flags=re.MULTILINE)
test_str = ("h1,h2,h3\n"
"A1,age:15,hh\n"
"B3,age:10,fg")
subst = "\\1\\2 years"
result = regex.sub(subst, test_str)
if result:
print(result)