use strict;
my $str = 'h1,h2,h3
A1,age:15,hh
B3,age:10,fg';
my $regex = qr/(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)/mp;
my $subst = '\\1\\2 years';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";