import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(,|^)(?:age\\s*(?:\\(years\\))?:\\s*(\\d+)\\s*(?:years)?)(?=,|$)";
final String string = "h1,h2,h3\n"
+ "A1,age:15,hh\n"
+ "B3,age:10,fg";
final String subst = "\\1\\2 years";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}