re = /(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)/m
str = 'h1,h2,h3
A1,age:15,hh
B3,age:10,fg'
subst = '\\1\\2 years'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result