$re = '/(,|^)(?:age\s*(?:\(years\))?:\s*(\d+)\s*(?:years)?)(?=,|$)/m';
$str = 'h1,h2,h3
A1,age:15,hh
B3,age:10,fg';
$subst = "\1\2 years";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;