import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=<a href)";
final String string = "\n"
+ " <p>Aquí va la additional information:<\\/p>\\r\\n<p>Es importante que el <a href=\"https://en.wikipedia.org/wiki/Ali_Dia\">tío de verdad<\\/a> no lea las chorradas que inventamos, que los de Ice Hockey están muy cuadrados y pagen pegar con los puños<\\/p><p>Aquí van los <a href=\\\"https://en.wikipedia.org/wiki/Carlos_Kaiser_(footballer)\\\">competition highlights<\\/a> del tío (Historical Results)<\\/p>\\r\\n<p>Bon diaaa<\\/p>\"},\n\n";
final String subst = "hello";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}