# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=<a href)"
test_str = ("\n"
" <p>Aquí va la additional information:<\\/p>\\r\\n<p>Es importante que el <a href=\"https://en.wikipedia.org/wiki/Ali_Dia\">tío de verdad<\\/a> no lea las chorradas que inventamos, que los de Ice Hockey están muy cuadrados y pagen pegar con los puños<\\/p><p>Aquí van los <a href=\\\"https://en.wikipedia.org/wiki/Carlos_Kaiser_(footballer)\\\">competition highlights<\\/a> del tío (Historical Results)<\\/p>\\r\\n<p>Bon diaaa<\\/p>\"},\n\n")
subst = "hello"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.