import Foundation
let pattern = #"(?=<a href)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>Aquí va la additional information:<\/p>\r\n<p>Es importante que el <a href="https://en.wikipedia.org/wiki/Ali_Dia">tío de verdad<\/a> no lea las chorradas que inventamos, que los de Ice Hockey están muy cuadrados y pagen pegar con los puños<\/p><p>Aquí van los <a href=\"https://en.wikipedia.org/wiki/Carlos_Kaiser_(footballer)\">competition highlights<\/a> del tío (Historical Results)<\/p>\r\n<p>Bon diaaa<\/p>"},
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"hello"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)