const regex = new RegExp('(?=<a href)', 'gm')
const str = `
<p>Aquí va la additional information:<\\/p>\\r\\n<p>Es importante que el <a href="https://en.wikipedia.org/wiki/Ali_Dia">tío de verdad<\\/a> no lea las chorradas que inventamos, que los de Ice Hockey están muy cuadrados y pagen pegar con los puños<\\/p><p>Aquí van los <a href=\\"https://en.wikipedia.org/wiki/Carlos_Kaiser_(footballer)\\">competition highlights<\\/a> del tío (Historical Results)<\\/p>\\r\\n<p>Bon diaaa<\\/p>"},
`;
const subst = `hello`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);