use strict;
my $str = '
<p>Aquí va la additional information:<\\/p>\\r\\n<p>Es importante que el <a href="https://en.wikipedia.org/wiki/Ali_Dia">tío de verdad<\\/a> no lea las chorradas que inventamos, que los de Ice Hockey están muy cuadrados y pagen pegar con los puños<\\/p><p>Aquí van los <a href=\\"https://en.wikipedia.org/wiki/Carlos_Kaiser_(footballer)\\">competition highlights<\\/a> del tío (Historical Results)<\\/p>\\r\\n<p>Bon diaaa<\\/p>"},
';
my $regex = qr~(?=<a href)~mp;
my $subst = 'hello';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";