#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(.*?)(_Capital))?(.*?)_(State.*)"
Local $sString = "Bokaro_State_Jharkhand" & @CRLF & _
"Ranchi_Capital_State_Jharkhand" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\4\2_\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)