import Foundation
let pattern = #"^(?:(.*?)(_Capital))?(.*?)_(State.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Bokaro_State_Jharkhand
Ranchi_Capital_State_Jharkhand
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\4\2_\1\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)