const regex = /^(?:(.*?)(_Capital))?(.*?)_(State.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(.*?)(_Capital))?(.*?)_(State.*)', 'gm')
const str = `Bokaro_State_Jharkhand
Ranchi_Capital_State_Jharkhand
`;
const subst = `\4\2_\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);