$re = '/^(?:(.*?)(_Capital))?(.*?)_(State.*)/m';
$str = 'Bokaro_State_Jharkhand
Ranchi_Capital_State_Jharkhand
';
$subst = "\4\2_\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;